What’s Vulnerable › Vulnerabilities
CVE-2021-40691
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-09-29 · updated 2026-06-17
Description
A session hijack risk was identified in the Shibboleth authentication plugin.
Affected products
- Moodle: before 3.9.10; from 3.10.0 before 3.10.7; from 3.11.0 before 3.11.3 — fixed in 3.10.7, 3.11.3, 3.9.10
How to fix
Upgrade to a fixed version: Moodle 3.10.7, 3.11.3, 3.9.10. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=2043411
- https://bugzilla.redhat.com/show_bug.cgi?id=2043411
Get alerted when CVE-2021-40691 or the next vulnerability affects your stack