What’s Vulnerable › Vulnerabilities
CVE-2021-4070: Off-by-one Error in v2fly/v2ray-core
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-23 · updated 2026-06-17
- Weakness: CWE-193
Description
Off-by-one Error in GitHub repository v2fly/v2ray-core prior to 4.44.0.
Affected products
- v2fly/v2ray-core: before 4.44.0 — fixed in 4.44.0
How to fix
Upgrade to a fixed version: v2fly/v2ray-core 4.44.0. Check the vendor advisory for mitigations.
References
- https://github.com/v2fly/v2ray-core/commit/c1af2bfd7aa59a4482aa7f6ec4b9208c1d350b5c
- https://huntr.dev/bounties/8da19456-4d89-41ef-9781-a41efd6a1877
- https://github.com/v2fly/v2ray-core/commit/c1af2bfd7aa59a4482aa7f6ec4b9208c1d350b5c
- https://huntr.dev/bounties/8da19456-4d89-41ef-9781-a41efd6a1877
Get alerted when CVE-2021-4070 or the next vulnerability affects your stack