What’s Vulnerable › Vulnerabilities
CVE-2021-4072: Cross-site Scripting (XSS) - Stored in elgg/elgg
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-24 · updated 2026-06-17
- Weakness: CWE-79
Description
elgg is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected products
- Elgg: before 3.3.24 — fixed in 3.3.24
How to fix
Upgrade to a fixed version: Elgg 3.3.24. Check the vendor advisory for mitigations.
References
- https://github.com/elgg/elgg/commit/c30b17bf75256ed3fcc84e2083147cc3951423d0
- https://huntr.dev/bounties/74034253-732a-4251-a0f9-eca5f576c955
- https://github.com/elgg/elgg/commit/c30b17bf75256ed3fcc84e2083147cc3951423d0
- https://huntr.dev/bounties/74034253-732a-4251-a0f9-eca5f576c955
Get alerted when CVE-2021-4072 or the next vulnerability affects your stack