What’s Vulnerable › Vulnerabilities
CVE-2021-40720: Ops CLI Deserialization of Untrusted Data leads to Abritrary Code Execution
- Severity: critical (CVSS 10.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-15 · updated 2026-06-17
- Weakness: CWE-502
Description
Ops CLI version 2.0.4 (and earlier) is affected by a Deserialization of Untrusted Data vulnerability to achieve arbitrary code execution when the checkout_repo function is called on a maliciously crafted file. An attacker can leverage this to execute arbitrary code on the victim machine.
Affected products
- Adobe Ops-CLI: before 2.0.5 — fixed in 2.0.5
How to fix
Upgrade to a fixed version: Adobe Ops-CLI 2.0.5. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/ops_cli/apsb21-88.html
- https://helpx.adobe.com/security/products/ops_cli/apsb21-88.html
Get alerted when CVE-2021-40720 or the next vulnerability affects your stack