What’s Vulnerable › Vulnerabilities
CVE-2021-40723: Acrobat Reader DC Out-Of-Bounds Read Information Disclosure Vulnerability
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-09-07 · updated 2026-06-17
- Weakness: CWE-125
Description
Acrobat Reader DC versions versions 2020.013.20074 (and earlier), 2020.001.30018 (and earlier) and 2017.011.30188 (and earlier) are affected by an out-of-bounds read vulnerability that could lead to disclosure of sensitive memory. An attacker could leverage this vulnerability to bypass mitigations such as ASLR. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
Affected products
- Adobe Acrobat for Edge: before 20.001.30020; from 20.0 before 20.001.30020 — fixed in 20.001.30020
- Adobe Acrobat DC: before 21.001.20135 — fixed in 21.001.20135
- Adobe Acrobat Reader: before 17.011.30190; from 20.0 before 20.001.30020 — fixed in 17.011.30190, 20.001.30020
- Adobe Acrobat Reader: before 21.001.20135 — fixed in 21.001.20135
How to fix
Upgrade to a fixed version: Adobe Acrobat for Edge 20.001.30020; Adobe Acrobat DC 21.001.20135; Adobe Acrobat Reader 17.011.30190, 20.001.30020; Adobe Acrobat Reader 21.001.20135. Check the vendor advisory for mitigations.
References
- https://helpx.adobe.com/security/products/acrobat/apsb21-09.html
- https://helpx.adobe.com/security/products/acrobat/apsb21-09.html
Get alerted when CVE-2021-40723 or the next vulnerability affects your stack