What’s Vulnerable › Vulnerabilities
CVE-2021-4081: Cross-site Scripting (XSS) - Reflected in pimcore/pimcore
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-10 · updated 2026-06-17
- Weakness: CWE-79
Description
pimcore is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected products
- pimcore/pimcore: before 10.2.6 — fixed in 10.2.6
How to fix
Upgrade to a fixed version: pimcore/pimcore 10.2.6. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/pimcore/commit/34ed0e050ff679b4b38414aef48ea1ff956f907a
- https://huntr.dev/bounties/da173e66-76ba-4f98-b8fb-429aabf222d3
- https://github.com/pimcore/pimcore/commit/34ed0e050ff679b4b38414aef48ea1ff956f907a
- https://huntr.dev/bounties/da173e66-76ba-4f98-b8fb-429aabf222d3
Get alerted when CVE-2021-4081 or the next vulnerability affects your stack