What’s Vulnerable › Vulnerabilities
CVE-2021-40822
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 19.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-05-02 · updated 2026-06-17
- Weakness: CWE-918
Description
GeoServer through 2.18.5 and 2.19.x through 2.19.2 allows SSRF via the option for setting a proxy host.
Affected products
- geoserver org.geoserver.extension:gs-db2: through 2.18.5; from 2.19.0 before 2.19.3 — fixed in 2.19.3
How to fix
Upgrade to a fixed version: geoserver org.geoserver.extension:gs-db2 2.19.3. Check the vendor advisory for mitigations.
References
- https://github.com/geoserver/geoserver/compare/2.19.2...2.19.3
- https://github.com/geoserver/geoserver/releases
- https://osgeo-org.atlassian.net/browse/GEOS-10229
- https://osgeo-org.atlassian.net/browse/GEOS-10229?focusedCommentId=83508
- https://github.com/geoserver/geoserver/compare/2.19.2...2.19.3
- https://github.com/geoserver/geoserver/releases
- https://osgeo-org.atlassian.net/browse/GEOS-10229
- https://osgeo-org.atlassian.net/browse/GEOS-10229?focusedCommentId=83508
Get alerted when CVE-2021-40822 or the next vulnerability affects your stack