What’s Vulnerable › Vulnerabilities
CVE-2021-4084: Cross-site Scripting (XSS) - Stored in pimcore/pimcore
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-10 · updated 2026-06-17
- Weakness: CWE-79
Description
pimcore is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected products
- pimcore/pimcore: before 10.2.6 — fixed in 10.2.6
How to fix
Upgrade to a fixed version: pimcore/pimcore 10.2.6. Check the vendor advisory for mitigations.
References
- https://github.com/pimcore/pimcore/commit/3c2a14e676a57e5d77a16255965988eef48f9065
- https://huntr.dev/bounties/dcb37f19-ba53-4498-b953-d21999279266
- https://github.com/pimcore/pimcore/commit/3c2a14e676a57e5d77a16255965988eef48f9065
- https://huntr.dev/bounties/dcb37f19-ba53-4498-b953-d21999279266
Get alerted when CVE-2021-4084 or the next vulnerability affects your stack