What’s Vulnerable › Vulnerabilities
CVE-2021-40864
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-10 · updated 2026-06-17
Description
The Translate plugin 6.1.x through 6.3.x before 6.3.0.72 for ONLYOFFICE Document Server lacks escape calls for the msg.data and text fields.
Affected products
- ONLYOFFICE Google Translate: from 6.1.0 before 6.3.0.72 — fixed in 6.3.0.72
How to fix
Upgrade to a fixed version: ONLYOFFICE Google Translate 6.3.0.72. Check the vendor advisory for mitigations.
References
- https://github.com/ONLYOFFICE/plugin-translator/commit/2206c0179cb97e3b8b290a0ab5719b1f0f54542b
- https://github.com/ONLYOFFICE/plugin-translator/compare/v6.3.0.71...v6.3.0.72
- https://github.com/ONLYOFFICE/plugin-translator/commit/2206c0179cb97e3b8b290a0ab5719b1f0f54542b
- https://github.com/ONLYOFFICE/plugin-translator/compare/v6.3.0.71...v6.3.0.72
Get alerted when CVE-2021-40864 or the next vulnerability affects your stack