What’s Vulnerable › Vulnerabilities
CVE-2021-40865: Unsafe Pre-Authentication Deserialization In Workers
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 64.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-25 · updated 2026-06-17
- Weakness: CWE-502
Description
An Unsafe Deserialization vulnerability exists in the worker services of the Apache Storm supervisor server allowing pre-auth Remote Code Execution (RCE). Apache Storm 2.2.x users should upgrade to version 2.2.1 or 2.3.0. Apache Storm 2.1.x users should upgrade to version 2.1.1. Apache Storm 1.x users should upgrade to version 1.2.4
Affected products
- Apache Software Foundation Apache Storm: from 1.0.0 before 1.2.4; from 2.1.0 before 2.1.1; from 2.2.0 before 2.2.1 — fixed in 1.2.4, 2.1.1, 2.2.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Storm 1.2.4, 2.1.1, 2.2.1. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/r8d45e74299897b6734dd0f788c46a631009ce2eeb731523386f7a253%40%3Cuser.storm.apache.org%3E
- https://seclists.org/oss-sec/2021/q4/45
- https://lists.apache.org/thread.html/r8d45e74299897b6734dd0f788c46a631009ce2eeb731523386f7a253%40%3Cuser.storm.apache.org%3E
- https://seclists.org/oss-sec/2021/q4/45
Get alerted when CVE-2021-40865 or the next vulnerability affects your stack