What’s Vulnerable › Vulnerabilities
CVE-2021-40926
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-01 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in demos/demo.mysqli.php in getID3 1.X and v2.0.0-beta allows remote attackers to inject arbitrary web script or HTML via the showtagfiles parameter.
Affected products
- Getid3: from 1.9.0 before 2.0.0; 2.0.0-beta — fixed in 2.0.0
How to fix
Upgrade to a fixed version: Getid3 2.0.0. Check the vendor advisory for mitigations.
References
- https://github.com/JamesHeinrich/getID3
- https://github.com/JamesHeinrich/getID3/issues/341
- https://github.com/JamesHeinrich/getID3
- https://github.com/JamesHeinrich/getID3/issues/341
Get alerted when CVE-2021-40926 or the next vulnerability affects your stack