What’s Vulnerable › Vulnerabilities
CVE-2021-41016
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-02 · updated 2026-06-17
- Weakness: CWE-78
Description
A improper neutralization of special elements used in a command ('command injection') in Fortinet FortiExtender version 7.0.1 and below, 4.2.3 and below, 4.1.7 and below allows an authenticated attacker to execute privileged shell commands via CLI commands including special characters
Affected products
- Fortinet FortiExtender: from 4.1.1 before 4.1.8; from 4.2.0 before 4.2.4; from 7.0.0 before 7.0.2 — fixed in 4.1.8, 4.2.4, 7.0.2
How to fix
Upgrade to a fixed version: Fortinet FortiExtender 4.1.8, 4.2.4, 7.0.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-41016 or the next vulnerability affects your stack