What’s Vulnerable › Vulnerabilities
CVE-2021-41018
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-02-02 · updated 2026-06-17
- Weakness: CWE-78
Description
A improper neutralization of special elements used in an os command ('os command injection') in Fortinet FortiWeb version 6.4.1 and below, 6.3.15 and below allows attacker to execute unauthorized code or commands via crafted HTTP requests.
Affected products
- Fortinet FortiWeb: from 6.2.0 before 6.2.7; from 6.3.0 before 6.3.16; from 6.4.0 before 6.4.2 — fixed in 6.2.7, 6.3.16, 6.4.2
How to fix
Upgrade to a fixed version: Fortinet FortiWeb 6.2.7, 6.3.16, 6.4.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-41018 or the next vulnerability affects your stack