What’s Vulnerable › Vulnerabilities
CVE-2021-41033
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-13 · updated 2026-06-17
- Weakness: CWE-300
Description
In all released versions of Eclipse Equinox, at least until version 4.21 (September 2021), installation can be vulnerable to man-in-the-middle attack if using p2 repos that are HTTP; that can then be exploited to serve incorrect p2 metadata and entirely alter the local installation, particularly by installing plug-ins that may then run malicious code.
Affected products
- eclipse Equinox: before 4.21; 4.21 — fixed in 4.21
How to fix
Upgrade to a fixed version: eclipse Equinox 4.21. Check the vendor advisory for mitigations.
References
- https://bugs.eclipse.org/bugs/show_bug.cgi?id=575688
- https://bugs.eclipse.org/bugs/show_bug.cgi?id=575688
Get alerted when CVE-2021-41033 or the next vulnerability affects your stack