What’s Vulnerable › Vulnerabilities
CVE-2021-4104: Deserialization of untrusted data in JMSAppender in Apache Log4j 1.2
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 80.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-14 · updated 2026-06-17
- Weakness: CWE-502
Description
JMSAppender in Log4j 1.2 is vulnerable to deserialization of untrusted data when the attacker has write access to the Log4j configuration. The attacker can provide TopicBindingName and TopicConnectionFactoryBindingName configurations causing JMSAppender to perform JNDI requests that result in remote code execution in a similar fashion to CVE-2021-44228. Note this issue only affects Log4j 1.2 when specifically configured to use JMSAppender, which is not the default. Apache Log4j 1.2 reached end of life in August 2015. Users should upgrade to Log4j 2 as it addresses numerous other issues from the previous versions.
Affected products
- Apache Log4j: 1.2
- Fedoraproject Fedora: 35
- Oracle Corporation Oracle Advanced Supply Chain Planning: 12.1, 12.2
- Oracle Corporation Oracle Business Intelligence Enterprise Edition: 5.9.0.0.0, 12.2.1.3.0, 12.2.1.4.0
- Oracle Corporation Oracle Business Process Management Suite: 12.2.1.3.0, 12.2.1.4.0
- Oracle Communications Eagle Ftp Table Base Retrieval: 4.5
- Oracle Communications Messaging Server: 8.1
- Oracle Communications Network Integrity: 7.3.6
- Oracle Communications Offline Mediation Controller: before 12.0.0.4.0; 12.0.0.5.0 — fixed in 12.0.0.4.0
- Oracle Corporation Oracle Communications Unified Inventory Management: 7.3.4, 7.3.5, 7.4.1, 7.4.2
- Oracle E-Business Suite Cloud Manager And Cloud Backup Module: 2.2.1.1.1
- Oracle Corporation Enterprise Manager Base Platform: 13.4.0.0, 13.5.0.0
- Oracle Financial Services Revenue Management And Billing Analytics: 2.7.0.0, 2.7.0.1, 2.8.0.0
- Oracle Fusion Middleware Common Libraries And Tools: 12.2.1.4.0
- Oracle Corporation Oracle GoldenGate: all versions
- Oracle Healthcare Data Repository: 8.1.0
- Oracle Corporation Oracle Hyperion Data Relationship Management: before 11.2.8.0 — fixed in 11.2.8.0
- Oracle Corporation Oracle Hyperion Infrastructure Technology: before 11.2.8.0 — fixed in 11.2.8.0
- Oracle Identity Management Suite: 12.2.1.3.0, 12.2.1.4.0
- Oracle Corporation Oracle JDeveloper: 12.2.1.3.0
- Oracle Corporation MySQL Enterprise Monitor: through 8.0.29
- Oracle Retail Allocation: 14.1.3.2, 15.0.3.1, 16.0.3, 19.0.1
- Oracle Retail Extract Transform And Load: 13.2.5
- Oracle Stream Analytics: all versions
- Oracle Timesten Grid: all versions
- Oracle Corporation Tuxedo: 12.2.2.0.0
- Oracle Utilities Testing Accelerator: 6.0.0.1.1, 6.0.0.2.2, 6.0.0.3.1
- Oracle WebLogic Server: 12.2.1.3.0, 12.2.1.4.0, 14.1.1.0.0
- RedHat Codeready Studio: 12.0
- Red Hat Enterprise Linux: 6.0, 7.0, 8.0
How to fix
Upgrade to a fixed version: Oracle Communications Offline Mediation Controller 12.0.0.4.0; Oracle Corporation Oracle Hyperion Data Relationship Management 11.2.8.0; Oracle Corporation Oracle Hyperion Infrastructure Technology 11.2.8.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2022/01/18/3
- https://access.redhat.com/security/cve/CVE-2021-4104
- https://github.com/apache/logging-log4j2/pull/608#issuecomment-990494126
- https://psirt.global.sonicwall.com/vuln-detail/SNWLID-2021-0033
- https://security.gentoo.org/glsa/202209-02
- https://security.gentoo.org/glsa/202310-16
- https://security.gentoo.org/glsa/202312-02
- https://security.gentoo.org/glsa/202312-04
- https://security.netapp.com/advisory/ntap-20211223-0007/
- https://www.cve.org/CVERecord?id=CVE-2021-44228
- https://www.kb.cert.org/vuls/id/930724
- https://www.oracle.com/security-alerts/cpuapr2022.html
Get alerted when CVE-2021-4104 or the next vulnerability affects your stack