What’s Vulnerable › Vulnerabilities
CVE-2021-4108: Cross-site Scripting (XSS) - Stored in snipe/snipe-it
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-14 · updated 2026-06-17
- Weakness: CWE-79
Description
snipe-it is vulnerable to Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Affected products
- grokability snipe-it: before 5.3.5 — fixed in 5.3.5
How to fix
Upgrade to a fixed version: grokability snipe-it 5.3.5. Check the vendor advisory for mitigations.
References
- https://github.com/snipe/snipe-it/commit/9d5d1a9f9aae2c8baee48551185da5de0cdb62c2
- https://huntr.dev/bounties/5069a037-040e-4d77-8526-846e65edfaf4
- https://github.com/snipe/snipe-it/commit/9d5d1a9f9aae2c8baee48551185da5de0cdb62c2
- https://huntr.dev/bounties/5069a037-040e-4d77-8526-846e65edfaf4
Get alerted when CVE-2021-4108 or the next vulnerability affects your stack