What’s Vulnerable › Vulnerabilities
CVE-2021-41086: Clipboard-based XSS in jsuites
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-21 · updated 2026-06-17
- Weakness: CWE-79
Description
jsuites is an open source collection of common required javascript web components. In affected versions users are subject to cross site scripting (XSS) attacks via clipboard content. jsuites is vulnerable to DOM based XSS if the user can be tricked into copying _anything_ from a malicious and pasting it into the html editor. This is because a part of the clipboard content is directly written to `innerHTML` allowing for javascript injection and thus XSS. Users are advised to update to version 4.9.11 to resolve.
Affected products
- jsuites: before 4.9.11 — fixed in 4.9.11
How to fix
Upgrade to a fixed version: jsuites 4.9.11. Check the vendor advisory for mitigations.
References
- https://github.com/jsuites/jsuites/commit/d47a6f4e143188dde2742f4cffd313e1068ad3b3
- https://github.com/jsuites/jsuites/commit/fe1d3cc5e339f2f4da8ed1f9f42271fdf9cbd8d2
- https://github.com/jsuites/jsuites/security/advisories/GHSA-qh7x-j4v8-qw5w
- https://github.com/jsuites/jsuites/commit/d47a6f4e143188dde2742f4cffd313e1068ad3b3
- https://github.com/jsuites/jsuites/commit/fe1d3cc5e339f2f4da8ed1f9f42271fdf9cbd8d2
- https://github.com/jsuites/jsuites/security/advisories/GHSA-qh7x-j4v8-qw5w
Get alerted when CVE-2021-41086 or the next vulnerability affects your stack