What’s Vulnerable › Vulnerabilities
CVE-2021-41121: Memory corruption in Vyper
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-06 · updated 2026-06-17
- Weakness: CWE-119
Description
Vyper is a Pythonic Smart Contract Language for the EVM. In affected versions when performing a function call inside a literal struct, there is a memory corruption issue that occurs because of an incorrect pointer to the the top of the stack. This issue has been resolved in version 0.3.0.
Affected products
- vyperlang vyper: before 0.3.0 — fixed in 0.3.0
How to fix
Upgrade to a fixed version: vyperlang vyper 0.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/vyperlang/vyper/pull/2447
- https://github.com/vyperlang/vyper/security/advisories/GHSA-xv8x-pr4h-73jv
- https://github.com/vyperlang/vyper/pull/2447
- https://github.com/vyperlang/vyper/security/advisories/GHSA-xv8x-pr4h-73jv
Get alerted when CVE-2021-41121 or the next vulnerability affects your stack