What’s Vulnerable › Vulnerabilities
CVE-2021-41122: Bounds check missing for decimal args in Vyper
- Severity: medium (CVSS 4.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-10-05 · updated 2026-06-17
- Weakness: CWE-682
Description
Vyper is a Pythonic Smart Contract Language for the EVM. In affected versions external functions did not properly validate the bounds of decimal arguments. The can lead to logic errors. This issue has been resolved in version 0.3.0.
Affected products
- vyperlang vyper: before 0.3.0 — fixed in 0.3.0
How to fix
Upgrade to a fixed version: vyperlang vyper 0.3.0. Check the vendor advisory for mitigations.
References
- https://github.com/vyperlang/vyper/pull/2447
- https://github.com/vyperlang/vyper/security/advisories/GHSA-c7pr-343r-5c46
- https://github.com/vyperlang/vyper/pull/2447
- https://github.com/vyperlang/vyper/security/advisories/GHSA-c7pr-343r-5c46
Get alerted when CVE-2021-41122 or the next vulnerability affects your stack