What’s Vulnerable › Vulnerabilities
CVE-2021-41125: HTTP authentication credential leak to target websites in scrapy
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-06 · updated 2026-06-17
- Weakness: CWE-200
Description
Scrapy is a high-level web crawling and scraping framework for Python. If you use `HttpAuthMiddleware` (i.e. the `http_user` and `http_pass` spider attributes) for HTTP authentication, all requests will expose your credentials to the request target. This includes requests generated by Scrapy components, such as `robots.txt` requests sent by Scrapy when the `ROBOTSTXT_OBEY` setting is set to `True`, or as requests reached through redirects. Upgrade to Scrapy 2.5.1 and use the new `http_auth_domain` spider attribute to control which domains are allowed to receive the configured HTTP authentication credentials. If you are using Scrapy 1.8 or a lower version, and upgrading to Scrapy 2.5.1 is not an option, you may upgrade to Scrapy 1.8.1 instead. If you cannot upgrade, set your HTTP authentication credentials on a per-request basis, using for example the `w3lib.http.basic_auth_header` function to convert your credentials into a value that you can assign to the `Authorization` header of your request, instead of defining your credentials globally using `HttpAuthMiddleware`.
Affected products
- Debian Linux: 9.0
- scrapy/scrapy: before 1.8.1; from 2.0.0 before 2.5.1 — fixed in 1.8.1, 2.5.1
How to fix
Upgrade to a fixed version: scrapy/scrapy 1.8.1, 2.5.1. Check the vendor advisory for mitigations.
References
- http://doc.scrapy.org/en/latest/topics/downloader-middleware.html#module-scrapy.downloadermiddlewares.httpauth
- https://github.com/scrapy/scrapy/commit/b01d69a1bf48060daec8f751368622352d8b85a6
- https://github.com/scrapy/scrapy/security/advisories/GHSA-jwqp-28gf-p498
- https://lists.debian.org/debian-lts-announce/2022/03/msg00021.html
- https://w3lib.readthedocs.io/en/latest/w3lib.html#w3lib.http.basic_auth_header
- http://doc.scrapy.org/en/latest/topics/downloader-middleware.html#module-scrapy.downloadermiddlewares.httpauth
- https://github.com/scrapy/scrapy/commit/b01d69a1bf48060daec8f751368622352d8b85a6
- https://github.com/scrapy/scrapy/security/advisories/GHSA-jwqp-28gf-p498
- https://lists.debian.org/debian-lts-announce/2022/03/msg00021.html
- https://w3lib.readthedocs.io/en/latest/w3lib.html#w3lib.http.basic_auth_header
Get alerted when CVE-2021-41125 or the next vulnerability affects your stack