What’s Vulnerable › Vulnerabilities
CVE-2021-41136: Inconsistent Interpretation of HTTP Requests ('HTTP Request Smuggling') in puma
- Severity: low (CVSS 3.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-12 · updated 2026-06-17
- Weakness: CWE-444
Description
Puma is a HTTP 1.1 server for Ruby/Rack applications. Prior to versions 5.5.1 and 4.3.9, using `puma` with a proxy which forwards HTTP header values which contain the LF character could allow HTTP request smugggling. A client could smuggle a request through a proxy, causing the proxy to send a response back to another unknown client. The only proxy which has this behavior, as far as the Puma team is aware of, is Apache Traffic Server. If the proxy uses persistent connections and the client adds another request in via HTTP pipelining, the proxy may mistake it as the first request's body. Puma, however, would see it as two requests, and when processing the second request, send back a response that the proxy does not expect. If the proxy has reused the persistent connection to Puma to send another request for a different client, the second response from the first client will be sent to the second client. This vulnerability was patched in Puma 5.5.1 and 4.3.9. As a workaround, do not use Apache Traffic Server with `puma`.
Affected products
- Debian Linux: 10.0, 11.0
- puma: through 4.3.8; from 5.0.0 through 5.5.0
- Rubygems Puma: from 5.0.0 before 5.5.1; before 4.3.9; 5.0.0, 5.0.1, 5.0.2, 5.0.3, 5.0.4, 5.1.0 (+132) — fixed in 5.5.1, 4.3.9
How to fix
Upgrade to a fixed version: Rubygems Puma 5.5.1, 4.3.9. Check the vendor advisory for mitigations.
References
- https://github.com/puma/puma/commit/436c71807f00e07070902a03f79fd3e130eb6b18
- https://github.com/puma/puma/commit/acdc3ae571dfae0e045cf09a295280127db65c7f
- https://github.com/puma/puma/commit/fb6ad8f8013ab5cdbb2f444cbfabd0b4fde71139
- https://github.com/puma/puma/security/advisories/GHSA-48w2-rm65-62xx
- https://github.com/puma/puma/commit/acdc3ae571dfae0e045cf09a295280127db65c7f
- https://github.com/puma/puma/security/advisories/GHSA-48w2-rm65-62xx
- https://lists.debian.org/debian-lts-announce/2022/08/msg00015.html
- https://security.gentoo.org/glsa/202208-28
- https://www.debian.org/security/2022/dsa-5146
Get alerted when CVE-2021-41136 or the next vulnerability affects your stack