What’s Vulnerable › Vulnerabilities
CVE-2021-41144: OpenMage LTS authenticated remote code execution through layout update
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-27 · updated 2026-06-17
- Weakness: CWE-77
Description
OpenMage LTS is an e-commerce platform. Prior to versions 19.4.22 and 20.0.19, a layout block was able to bypass the block blacklist to execute remote code. Versions 19.4.22 and 20.0.19 contain a patch for this issue.
Affected products
- OpenMage magento-lts: before 19.4.22; from 20.0.0 before 20.0.19 — fixed in 19.4.22, 20.0.19
How to fix
Upgrade to a fixed version: OpenMage magento-lts 19.4.22, 20.0.19. Check the vendor advisory for mitigations.
References
- https://github.com/OpenMage/magento-lts/commit/06c45940ba3256cdfc9feea12a3c0ca56d23acf8
- https://github.com/OpenMage/magento-lts/releases/tag/v19.4.22
- https://github.com/OpenMage/magento-lts/releases/tag/v20.0.19
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-5j2g-3ph4-rgvm
- https://github.com/OpenMage/magento-lts/commit/06c45940ba3256cdfc9feea12a3c0ca56d23acf8
- https://github.com/OpenMage/magento-lts/releases/tag/v19.4.22
- https://github.com/OpenMage/magento-lts/releases/tag/v20.0.19
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-5j2g-3ph4-rgvm
Get alerted when CVE-2021-41144 or the next vulnerability affects your stack