What’s Vulnerable › Vulnerabilities
CVE-2021-41148: The update of the CI job targeted by a widget is vulnerable to blind SQL injections
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-15 · updated 2026-06-17
- Weakness: CWE-89
Description
Tuleap Open ALM is a libre and open source tool for end to end traceability of application and system developments. Prior to version 11.16.99.173 of Community Edition and versions 11.16-6 and 11.15-8 of Enterprise Edition, an attacker with the ability to add one the CI widget to its personal dashboard could execute arbitrary SQL queries. Tuleap Community Edition 11.16.99.173, Tuleap Enterprise Edition 11.16-6, and Tuleap Enterprise Edition 11.15-8 contain a patch for this issue.
Affected products
- Enalean tuleap: before 11.16.99.173; from 11.15-1 before 11.15-8; from 11.16-1 before 11.16-6 — fixed in 11.15-8, 11.16-6, 11.16.99.173
How to fix
Upgrade to a fixed version: Enalean tuleap 11.15-8, 11.16-6, 11.16.99.173. Check the vendor advisory for mitigations.
References
- https://github.com/Enalean/tuleap/commit/91535add59f4b3a04b6b8eab123c002cd5af180d
- https://github.com/Enalean/tuleap/security/advisories/GHSA-3c4q-8c35-cp63
- https://tuleap.net/plugins/git/tuleap/tuleap/stable?a=commit&h=91535add59f4b3a04b6b8eab123c002cd5af180d
- https://tuleap.net/plugins/tracker/?aid=15028
- https://github.com/Enalean/tuleap/commit/91535add59f4b3a04b6b8eab123c002cd5af180d
- https://github.com/Enalean/tuleap/security/advisories/GHSA-3c4q-8c35-cp63
- https://tuleap.net/plugins/git/tuleap/tuleap/stable?a=commit&h=91535add59f4b3a04b6b8eab123c002cd5af180d
- https://tuleap.net/plugins/tracker/?aid=15028
Get alerted when CVE-2021-41148 or the next vulnerability affects your stack