What’s Vulnerable › Vulnerabilities
CVE-2021-41153: Specification non-compliance in JUMPI
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-18 · updated 2026-06-17
- Weakness: CWE-670
Description
The evm crate is a pure Rust implementation of Ethereum Virtual Machine. In `evm` crate `< 0.31.0`, `JUMPI` opcode's condition is checked after the destination validity check. However, according to Geth and OpenEthereum, the condition check should happen before the destination validity check. This is a **high** severity security advisory if you use `evm` crate for Ethereum mainnet. In this case, you should update your library dependency immediately to on or after `0.31.0`. This is a **low** severity security advisory if you use `evm` crate in Frontier or in a standalone blockchain, because there's no security exploit possible with this advisory. It is **not** recommended to update to on or after `0.31.0` until all the normal chain upgrade preparations have been done. If you use Frontier or other `pallet-evm` based Substrate blockchain, please ensure to update your `spec_version` before updating this. For other blockchains, please make sure to follow a hard-fork process before you update this.
Affected products
- rust-blockchain evm: before 0.31.0 — fixed in 0.31.0
How to fix
Upgrade to a fixed version: rust-blockchain evm 0.31.0. Check the vendor advisory for mitigations.
References
- https://github.com/rust-blockchain/evm/pull/67
- https://github.com/rust-blockchain/evm/security/advisories/GHSA-pvh2-pj76-4m96
- https://github.com/rust-blockchain/evm/pull/67
- https://github.com/rust-blockchain/evm/security/advisories/GHSA-pvh2-pj76-4m96
Get alerted when CVE-2021-41153 or the next vulnerability affects your stack