What’s Vulnerable › Vulnerabilities
CVE-2021-41163: RCE via malicious SNS subscription payload
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 19.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-20 · updated 2026-06-17
- Weakness: CWE-74
Description
Discourse is an open source platform for community discussion. In affected versions maliciously crafted requests could lead to remote code execution. This resulted from a lack of validation in subscribe_url values. This issue is patched in the latest stable, beta and tests-passed versions of Discourse. To workaround the issue without updating, requests with a path starting /webhooks/aws path could be blocked at an upstream proxy.
Affected products
- discourse: before 2.7.9; 2.8.0-beta1, 2.8.0-beta2, 2.8.0-beta3, 2.8.0-beta4, 2.8.0-beta5, 2.8.0-beta6 — fixed in 2.7.9
How to fix
Upgrade to a fixed version: discourse 2.7.9. Check the vendor advisory for mitigations.
References
- https://github.com/discourse/discourse/commit/fa3c46cf079d28b086fe1025349bb00223a5d5e9
- https://github.com/discourse/discourse/security/advisories/GHSA-jcjx-pvpc-qgwq
- https://github.com/discourse/discourse/commit/fa3c46cf079d28b086fe1025349bb00223a5d5e9
- https://github.com/discourse/discourse/security/advisories/GHSA-jcjx-pvpc-qgwq
Get alerted when CVE-2021-41163 or the next vulnerability affects your stack