What’s Vulnerable › Vulnerabilities

CVE-2021-41164: Advanced Content Filter (ACF) vulnerability allowing to execute JavaScript code using malformed HTML

Description

CKEditor4 is an open source WYSIWYG HTML editor. In affected versions a vulnerability has been discovered in the Advanced Content Filter (ACF) module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0.

Affected products

How to fix

Upgrade to a fixed version: ckeditor4 4.17.0; Drupal 8.9.20, 9.1.14, 9.2.9; Oracle Corporation Application Express 22.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-41164 or the next vulnerability affects your stack