What’s Vulnerable › Vulnerabilities

CVE-2021-41165: HTML comments vulnerability allowing to execute JavaScript code

Description

CKEditor4 is an open source WYSIWYG HTML editor. In affected version a vulnerability has been discovered in the core HTML processing module and may affect all plugins used by CKEditor 4. The vulnerability allowed to inject malformed comments HTML bypassing content sanitization, which could result in executing JavaScript code. It affects all users using the CKEditor 4 at version < 4.17.0. The problem has been recognized and patched. The fix will be available in version 4.17.0.

Affected products

How to fix

Upgrade to a fixed version: ckeditor4 4.17.0; Drupal 8.9.20, 9.1.14, 9.2.9; Oracle Corporation Application Express 22.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-41165 or the next vulnerability affects your stack