What’s Vulnerable › Vulnerabilities
CVE-2021-41170: Evaluation of closures can lead to execution of methods & functions in current program scope
- Severity: high (CVSS 7.5 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-08 · updated 2026-06-17
- Weakness: CWE-74
Description
neoan3-apps/template is a neoan3 minimal template engine. Versions prior to 1.1.1 have allowed for passing in closures directly into the template engine. As a result values that are callable are executed by the template engine. The issue arises if a value has the same name as a method or function in scope and can therefore be executed either by mistake or maliciously. In theory all users of the package are affected as long as they either deal with direct user input or database values. A multi-step attack on is therefore plausible. Version 1.1.1 has addressed this vulnerability. Unfortunately only working with hardcoded values is safe in prior versions. As this likely defeats the purpose of a template engine, please upgrade.
Affected products
- sroehrl neoan3-template: before 1.1.1 — fixed in 1.1.1
How to fix
Upgrade to a fixed version: sroehrl neoan3-template 1.1.1. Check the vendor advisory for mitigations.
References
- https://github.com/sroehrl/neoan3-template/commit/4a2c9570f071d3c8f4ac790007599cba20e16934
- https://github.com/sroehrl/neoan3-template/issues/8
- https://github.com/sroehrl/neoan3-template/security/advisories/GHSA-3v56-q6r6-4gcw
- https://github.com/sroehrl/neoan3-template/commit/4a2c9570f071d3c8f4ac790007599cba20e16934
- https://github.com/sroehrl/neoan3-template/issues/8
- https://github.com/sroehrl/neoan3-template/security/advisories/GHSA-3v56-q6r6-4gcw
Get alerted when CVE-2021-41170 or the next vulnerability affects your stack