What’s Vulnerable › Vulnerabilities
CVE-2021-41178: File Traversal affecting SVG files on Nextcloud Server
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-25 · updated 2026-06-17
- Weakness: CWE-23
Description
Nextcloud is an open-source, self-hosted productivity platform. Prior to versions 20.0.13, 21.0.5, and 22.2.0, a file traversal vulnerability makes an attacker able to download arbitrary SVG images from the host system, including user provided files. This could also be leveraged into a XSS/phishing attack, an attacker could upload a malicious SVG file that mimics the Nextcloud login form and send a specially crafted link to victims. The XSS risk here is mitigated due to the fact that Nextcloud employs a strict Content-Security-Policy disallowing execution of arbitrary JavaScript. It is recommended that the Nextcloud Server be upgraded to 20.0.13, 21.0.5 or 22.2.0. There are no known workarounds aside from upgrading.
Affected products
- Nextcloud Server: from 20.0.3 before 20.0.13; from 21.0.1 before 21.0.5; from 22.1.1 before 22.2.0 — fixed in 20.0.13, 21.0.5, 22.2.0
How to fix
Upgrade to a fixed version: Nextcloud Server 20.0.13, 21.0.5, 22.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-jp9c-vpr3-m5rf
- https://github.com/nextcloud/server/pull/28726
- https://hackerone.com/reports/1302155
- https://security.gentoo.org/glsa/202208-17
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-jp9c-vpr3-m5rf
- https://github.com/nextcloud/server/pull/28726
- https://hackerone.com/reports/1302155
- https://security.gentoo.org/glsa/202208-17
Get alerted when CVE-2021-41178 or the next vulnerability affects your stack