What’s Vulnerable › Vulnerabilities
CVE-2021-41179: Two-Factor Authentication not enforced for pages marked as public
- Severity: medium (CVSS 4.0 v2.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-25 · updated 2026-06-17
- Weakness: CWE-304
Description
Nextcloud is an open-source, self-hosted productivity platform. Prior to Nextcloud Server versions 20.0.13, 21.0.5, and 22.2.0, the Two-Factor Authentication wasn't enforced for pages marked as public. Any page marked as `@PublicPage` could thus be accessed with a valid user session that isn't authenticated. This particularly affects the Nextcloud Talk application, as this could be leveraged to gain access to any private chat channel without going through the Two-Factor flow. It is recommended that the Nextcloud Server be upgraded to 20.0.13, 21.0.5 or 22.2.0. There are no known workarounds aside from upgrading.
Affected products
- Nextcloud Server: from 20.0.3 before 20.0.13; from 21.0.1 before 21.0.5; from 22.1.1 before 22.2.0 — fixed in 20.0.13, 21.0.5, 22.2.0
How to fix
Upgrade to a fixed version: Nextcloud Server 20.0.13, 21.0.5, 22.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-7hvh-rc6f-px23
- https://github.com/nextcloud/server/pull/28725
- https://hackerone.com/reports/1322865
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-7hvh-rc6f-px23
- https://github.com/nextcloud/server/pull/28725
- https://hackerone.com/reports/1322865
Get alerted when CVE-2021-41179 or the next vulnerability affects your stack