What’s Vulnerable › Vulnerabilities

CVE-2021-41182: XSS in the `altField` option of the Datepicker widget

Description

jQuery-UI is the official jQuery user interface library. Prior to version 1.13.0, accepting the value of the `altField` option of the Datepicker widget from untrusted sources may execute untrusted code. The issue is fixed in jQuery UI 1.13.0. Any string value passed to the `altField` option is now treated as a CSS selector. A workaround is to not accept the value of the `altField` option from untrusted sources.

Affected products

How to fix

Upgrade to a fixed version: Drupal 7.86; Jqueryui Jquery Ui 1.13.0; Oracle Corporation Application Express 22.1.1; Oracle Big Data Spatial And Graph 23.1; Oracle Corporation Oracle REST Data Services 22.1.1; Tenable.sc 5.21.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-41182 or the next vulnerability affects your stack