What’s Vulnerable › Vulnerabilities

CVE-2021-41183: XSS in `*Text` options of the Datepicker widget

Description

jQuery-UI is the official jQuery user interface library. Prior to version 1.13.0, accepting the value of various `*Text` options of the Datepicker widget from untrusted sources may execute untrusted code. The issue is fixed in jQuery UI 1.13.0. The values passed to various `*Text` options are now always treated as pure text, not HTML. A workaround is to not accept the value of the `*Text` options from untrusted sources.

Affected products

How to fix

Upgrade to a fixed version: Drupal 7.86, 9.2.11, 9.3.3; Jqueryui Jquery Ui 1.13.0; Oracle Corporation Application Express 22.1.1; Oracle Big Data Spatial And Graph 23.1; Oracle Corporation Oracle REST Data Services 22.1.1; Tenable.sc 5.21.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2021-41183 or the next vulnerability affects your stack