What’s Vulnerable › Vulnerabilities
CVE-2021-41188: Authenticated Stored XSS in Administration
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-26 · updated 2026-06-17
- Weakness: CWE-79
Description
Shopware is open source e-commerce software. Versions prior to 5.7.6 contain a cross-site scripting vulnerability. This issue is patched in version 5.7.6. Two workarounds are available. Using the security plugin or adding a particular following config to the `.htaccess` file will protect against cross-site scripting in this case. There is also a config for those using nginx as a server. The plugin and the configs can be found on the GitHub Security Advisory page for this vulnerability.
Affected products
- shopware: before 5.7.6 — fixed in 5.7.6
How to fix
Upgrade to a fixed version: shopware 5.7.6. Check the vendor advisory for mitigations.
References
- https://docs.shopware.com/en/shopware-5-en/sicherheitsupdates/security-update-10-2021
- https://github.com/shopware/shopware/commit/37213e91d525c95df262712cba80d1497e395a58
- https://github.com/shopware/shopware/releases/tag/v5.7.6
- https://github.com/shopware/shopware/security/advisories/GHSA-4p3x-8qw9-24w9
- https://store.shopware.com/en/swag575294366635f/shopware-security-plugin.html
- https://docs.shopware.com/en/shopware-5-en/sicherheitsupdates/security-update-10-2021
- https://github.com/shopware/shopware/commit/37213e91d525c95df262712cba80d1497e395a58
- https://github.com/shopware/shopware/releases/tag/v5.7.6
- https://github.com/shopware/shopware/security/advisories/GHSA-4p3x-8qw9-24w9
- https://store.shopware.com/en/swag575294366635f/shopware-security-plugin.html
Get alerted when CVE-2021-41188 or the next vulnerability affects your stack