What’s Vulnerable › Vulnerabilities
CVE-2021-41199: Overflow/crash in `tf.image.resize` when size is large
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-05 · updated 2026-06-17
- Weakness: CWE-190
Description
TensorFlow is an open source platform for machine learning. In affected versions if `tf.image.resize` is called with a large input argument then the TensorFlow process will crash due to a `CHECK`-failure caused by an overflow. The number of elements in the output tensor is too much for the `int64_t` type and the overflow is detected via a `CHECK` statement. This aborts the process. The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.
Affected products
- tensorflow: before 2.4.4; from 2.5.0 before 2.5.2; 2.6.0 — fixed in 2.4.4, 2.5.2
How to fix
Upgrade to a fixed version: tensorflow 2.4.4, 2.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/commit/e5272d4204ff5b46136a1ef1204fc00597e21837
- https://github.com/tensorflow/tensorflow/issues/46914
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-5hx2-qx8j-qjqm
- https://github.com/tensorflow/tensorflow/commit/e5272d4204ff5b46136a1ef1204fc00597e21837
- https://github.com/tensorflow/tensorflow/issues/46914
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-5hx2-qx8j-qjqm
Get alerted when CVE-2021-41199 or the next vulnerability affects your stack