What’s Vulnerable › Vulnerabilities
CVE-2021-4120: snapd could be made to bypass intended access restrictions through snap content interfaces and layout paths
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-02-17 · updated 2026-06-17
- Weakness: CWE-20
Description
snapd 2.54.2 fails to perform sufficient validation of snap content interface and layout paths, resulting in the ability for snaps to inject arbitrary AppArmor policy rules via malformed content interface and layout declarations and hence escape strict snap confinement. Fixed in snapd versions 2.54.3+18.04, 2.54.3+20.04 and 2.54.3+21.10.1
Affected products
- Canonical Ltd. snapd: through 2.54.2
- Canonical Ubuntu Linux: 18.04, 20.04, 21.10
- Fedoraproject Fedora: 34, 35
References
- http://www.openwall.com/lists/oss-security/2022/02/18/2
- https://bugs.launchpad.net/snapd/+bug/1949368
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3QTBN7LLZISXIA4KU4UKDR27Q5PXDS2U/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XCGHG6LJAVJJ72TMART6A7N4Z6MSTGI7/
- https://ubuntu.com/security/notices/USN-5292-1
- http://www.openwall.com/lists/oss-security/2022/02/18/2
- https://bugs.launchpad.net/snapd/+bug/1949368
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/3QTBN7LLZISXIA4KU4UKDR27Q5PXDS2U/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XCGHG6LJAVJJ72TMART6A7N4Z6MSTGI7/
- https://ubuntu.com/security/notices/USN-5292-1
Get alerted when CVE-2021-4120 or the next vulnerability affects your stack