What’s Vulnerable › Vulnerabilities
CVE-2021-41200: Incomplete validation in `tf.summary.create_file_writer`
- Severity: medium (CVSS 5.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-05 · updated 2026-06-17
- Weakness: CWE-617
Description
TensorFlow is an open source platform for machine learning. In affected versions if `tf.summary.create_file_writer` is called with non-scalar arguments code crashes due to a `CHECK`-fail. The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.
Affected products
- tensorflow: before 2.4.4; from 2.5.0 before 2.5.2; 2.6.0 — fixed in 2.4.4, 2.5.2
How to fix
Upgrade to a fixed version: tensorflow 2.4.4, 2.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/commit/874bda09e6702cd50bac90b453b50bcc65b2769e
- https://github.com/tensorflow/tensorflow/issues/46909
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-gh8h-7j2j-qv4f
- https://github.com/tensorflow/tensorflow/commit/874bda09e6702cd50bac90b453b50bcc65b2769e
- https://github.com/tensorflow/tensorflow/issues/46909
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-gh8h-7j2j-qv4f
Get alerted when CVE-2021-41200 or the next vulnerability affects your stack