What’s Vulnerable › Vulnerabilities
CVE-2021-41201: Unitialized access in `EinsumHelper::ParseEquation`
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-05 · updated 2026-06-17
- Weakness: CWE-824
Description
TensorFlow is an open source platform for machine learning. In affeced versions during execution, `EinsumHelper::ParseEquation()` is supposed to set the flags in `input_has_ellipsis` vector and `*output_has_ellipsis` boolean to indicate whether there is ellipsis in the corresponding inputs and output. However, the code only changes these flags to `true` and never assigns `false`. This results in unitialized variable access if callers assume that `EinsumHelper::ParseEquation()` always sets these flags. The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.
Affected products
- tensorflow: before 2.4.4; from 2.5.0 before 2.5.2; 2.6.0 — fixed in 2.4.4, 2.5.2
How to fix
Upgrade to a fixed version: tensorflow 2.4.4, 2.5.2. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/commit/f09caa532b6e1ac8d2aa61b7832c78c5b79300c6
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-j86v-p27c-73fm
- https://github.com/tensorflow/tensorflow/commit/f09caa532b6e1ac8d2aa61b7832c78c5b79300c6
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-j86v-p27c-73fm
Get alerted when CVE-2021-41201 or the next vulnerability affects your stack