What’s Vulnerable › Vulnerabilities
CVE-2021-41208: Incomplete validation in boosted trees code
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-05 · updated 2026-06-17
- Weakness: CWE-476
Description
TensorFlow is an open source platform for machine learning. In affected versions the code for boosted trees in TensorFlow is still missing validation. As a result, attackers can trigger denial of service (via dereferencing `nullptr`s or via `CHECK`-failures) as well as abuse undefined behavior (binding references to `nullptr`s). An attacker can also read and write from heap buffers, depending on the API that gets used and the arguments that are passed to the call. Given that the boosted trees implementation in TensorFlow is unmaintained, it is recommend to no longer use these APIs. We will deprecate TensorFlow's boosted trees APIs in subsequent releases. The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.
Affected products
- tensorflow: from 2.4.0 before 2.4.4; from 2.5.0 before 2.5.2; from 2.6.0 before 2.6.1; 2.7.0-rc0, 2.7.0-rc1 — fixed in 2.4.4, 2.5.2, 2.6.1
How to fix
Upgrade to a fixed version: tensorflow 2.4.4, 2.5.2, 2.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/commit/5c8c9a8bfe750f9743d0c859bae112060b216f5c
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-57wx-m983-2f88
- https://github.com/tensorflow/tensorflow/commit/5c8c9a8bfe750f9743d0c859bae112060b216f5c
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-57wx-m983-2f88
Get alerted when CVE-2021-41208 or the next vulnerability affects your stack