What’s Vulnerable › Vulnerabilities
CVE-2021-41216: Heap buffer overflow in `Transpose`
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-05 · updated 2026-06-17
- Weakness: CWE-120
Description
TensorFlow is an open source platform for machine learning. In affected versions the shape inference function for `Transpose` is vulnerable to a heap buffer overflow. This occurs whenever `perm` contains negative elements. The shape inference function does not validate that the indices in `perm` are all valid. The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.
Affected products
- tensorflow: from 2.4.0 before 2.4.4; from 2.5.0 before 2.5.2; from 2.6.0 before 2.6.1; 2.7.0-rc0, 2.7.0-rc1 — fixed in 2.4.4, 2.5.2, 2.6.1
How to fix
Upgrade to a fixed version: tensorflow 2.4.4, 2.5.2, 2.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/commit/c79ba87153ee343401dbe9d1954d7f79e521eb14
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-3ff2-r28g-w7h9
- https://github.com/tensorflow/tensorflow/commit/c79ba87153ee343401dbe9d1954d7f79e521eb14
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-3ff2-r28g-w7h9
Get alerted when CVE-2021-41216 or the next vulnerability affects your stack