What’s Vulnerable › Vulnerabilities
CVE-2021-41225: A use of uninitialized value vulnerability in Tensorflow
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-05 · updated 2026-06-17
- Weakness: CWE-908
Description
TensorFlow is an open source platform for machine learning. In affected versions TensorFlow's Grappler optimizer has a use of unitialized variable. If the `train_nodes` vector (obtained from the saved model that gets optimized) does not contain a `Dequeue` node, then `dequeue_node` is left unitialized. The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.
Affected products
- tensorflow: from 2.4.0 before 2.4.4; from 2.5.0 before 2.5.2; from 2.6.0 before 2.6.1; 2.7.0-rc0, 2.7.0-rc1 — fixed in 2.4.4, 2.5.2, 2.6.1
How to fix
Upgrade to a fixed version: tensorflow 2.4.4, 2.5.2, 2.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/commit/68867bf01239d9e1048f98cbad185bf4761bedd3
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-7r94-xv9v-63jw
- https://github.com/tensorflow/tensorflow/commit/68867bf01239d9e1048f98cbad185bf4761bedd3
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-7r94-xv9v-63jw
Get alerted when CVE-2021-41225 or the next vulnerability affects your stack