What’s Vulnerable › Vulnerabilities
CVE-2021-41228: Code injection in `saved_model_cli`
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-11-05 · updated 2026-06-17
- Weakness: CWE-78
Description
TensorFlow is an open source platform for machine learning. In affected versions TensorFlow's `saved_model_cli` tool is vulnerable to a code injection as it calls `eval` on user supplied strings. This can be used by attackers to run arbitrary code on the plaform where the CLI tool runs. However, given that the tool is always run manually, the impact of this is not severe. We have patched this by adding a `safe` flag which defaults to `True` and an explicit warning for users. The fix will be included in TensorFlow 2.7.0. We will also cherrypick this commit on TensorFlow 2.6.1, TensorFlow 2.5.2, and TensorFlow 2.4.4, as these are also affected and still in supported range.
Affected products
- tensorflow: from 2.4.0 before 2.4.4; from 2.5.0 before 2.5.2; from 2.6.0 before 2.6.1; 2.7.0-rc0, 2.7.0-rc1 — fixed in 2.4.4, 2.5.2, 2.6.1
How to fix
Upgrade to a fixed version: tensorflow 2.4.4, 2.5.2, 2.6.1. Check the vendor advisory for mitigations.
References
- https://github.com/tensorflow/tensorflow/commit/8b202f08d52e8206af2bdb2112a62fafbc546ec7
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-3rcw-9p9x-582v
- https://github.com/tensorflow/tensorflow/commit/8b202f08d52e8206af2bdb2112a62fafbc546ec7
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-3rcw-9p9x-582v
Get alerted when CVE-2021-41228 or the next vulnerability affects your stack