What’s Vulnerable › Vulnerabilities
CVE-2021-41231: OpenMage LTS DataFlow upload remote code execution vulnerability
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-01-27 · updated 2026-06-17
- Weakness: CWE-77
Description
OpenMage LTS is an e-commerce platform. Prior to versions 19.4.22 and 20.0.19, an administrator with the permissions to upload files via DataFlow and to create products was able to execute arbitrary code via the convert profile. Versions 19.4.22 and 20.0.19 contain a patch for this issue.
Affected products
- OpenMage magento-lts: before 19.4.22; from 20.0.0 before 20.0.19 — fixed in 19.4.22, 20.0.19
How to fix
Upgrade to a fixed version: OpenMage magento-lts 19.4.22, 20.0.19. Check the vendor advisory for mitigations.
References
- https://github.com/OpenMage/magento-lts/commit/d16fc6c5a1e66c6f0d9f82020f11702a7ddd78e4
- https://github.com/OpenMage/magento-lts/releases/tag/v19.4.22
- https://github.com/OpenMage/magento-lts/releases/tag/v20.0.19
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-h632-p764-pjqm
- https://github.com/OpenMage/magento-lts/commit/d16fc6c5a1e66c6f0d9f82020f11702a7ddd78e4
- https://github.com/OpenMage/magento-lts/releases/tag/v19.4.22
- https://github.com/OpenMage/magento-lts/releases/tag/v20.0.19
- https://github.com/OpenMage/magento-lts/security/advisories/GHSA-h632-p764-pjqm
Get alerted when CVE-2021-41231 or the next vulnerability affects your stack