What’s Vulnerable › Vulnerabilities
CVE-2021-41239: User enumeration setting not respected in Nextcloud server
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-03-08 · updated 2026-06-17
- Weakness: CWE-200
Description
Nextcloud server is a self hosted system designed to provide cloud style services. In affected versions the User Status API did not consider the user enumeration settings by the administrator. This allowed a user to enumerate other users on the instance, even when user listings where disabled. It is recommended that the Nextcloud Server is upgraded to 20.0.14, 21.0.6 or 22.2.1. There are no known workarounds.
Affected products
- Nextcloud Server: before 20.0.14; from 21.0.0 before 21.0.6; 22.2.0 — fixed in 20.0.14, 21.0.6
How to fix
Upgrade to a fixed version: Nextcloud Server 20.0.14, 21.0.6. Check the vendor advisory for mitigations.
References
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-g722-cm3h-8wrx
- https://github.com/nextcloud/server/issues/27122
- https://github.com/nextcloud/server/pull/29260
- https://security.gentoo.org/glsa/202208-17
- https://github.com/nextcloud/security-advisories/security/advisories/GHSA-g722-cm3h-8wrx
- https://github.com/nextcloud/server/issues/27122
- https://github.com/nextcloud/server/pull/29260
- https://security.gentoo.org/glsa/202208-17
Get alerted when CVE-2021-41239 or the next vulnerability affects your stack