What’s Vulnerable › Vulnerabilities
CVE-2021-41249: XSS vulnerability in GraphQL Playground
- Severity: medium (CVSS 4.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-11-04 · updated 2026-06-17
- Weakness: CWE-79
Description
GraphQL Playground is a GraphQL IDE for development of graphQL focused applications. All versions of graphql-playground-react older than graphql-playground-react@1.7.28 are vulnerable to compromised HTTP schema introspection responses or schema prop values with malicious GraphQL type names, exposing a dynamic XSS attack surface that can allow code injection on operation autocomplete. In order for the attack to take place, the user must load a malicious schema in graphql-playground. There are several ways this can occur, including by specifying the URL to a malicious schema in the endpoint query parameter. If a user clicks on a link to a GraphQL Playground installation that specifies a malicious server, arbitrary JavaScript can run in the user's browser, which can be used to exfiltrate user credentials or other harmful goals. If you are using graphql-playground-react directly in your client app, upgrade to version 1.7.28 or later.
Affected products
- graphql-playground: before 1.7.28 — fixed in 1.7.28
How to fix
Upgrade to a fixed version: graphql-playground 1.7.28. Check the vendor advisory for mitigations.
References
- https://github.com/graphql/graphiql/security/advisories/GHSA-x4r7-m2q9-69c8
- https://github.com/graphql/graphql-playground/commit/b8a956006835992f12c46b90384a79ab82bcadad
- https://github.com/graphql/graphql-playground/security/advisories/GHSA-59r9-6jp6-jcm7
- https://github.com/graphql/graphiql/security/advisories/GHSA-x4r7-m2q9-69c8
- https://github.com/graphql/graphql-playground/commit/b8a956006835992f12c46b90384a79ab82bcadad
- https://github.com/graphql/graphql-playground/security/advisories/GHSA-59r9-6jp6-jcm7
Get alerted when CVE-2021-41249 or the next vulnerability affects your stack