What’s Vulnerable › Vulnerabilities
CVE-2021-41261: Stored Cross-site Scripting in Galette
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-16 · updated 2026-06-17
- Weakness: CWE-79
Description
Galette is a membership management web application built for non profit organizations and released under GPLv3. Versions prior to 0.9.6 are subject to stored cross site scripting attacks via the preferences footer. The preference footer can only be altered by a site admin. This issue has been resolved in the 0.9.6 release and all users are advised to upgrade. There are no known workarounds.
Affected products
- galette: before 0.9.6 — fixed in 0.9.6
How to fix
Upgrade to a fixed version: galette 0.9.6. Check the vendor advisory for mitigations.
References
- https://github.com/galette/galette/commit/0d55bc7f420470e0dbca91ebe7899c592905cbc5
- https://github.com/galette/galette/security/advisories/GHSA-28fg-cp22-6c33
- https://github.com/galette/galette/commit/0d55bc7f420470e0dbca91ebe7899c592905cbc5
- https://github.com/galette/galette/security/advisories/GHSA-28fg-cp22-6c33
Get alerted when CVE-2021-41261 or the next vulnerability affects your stack