What’s Vulnerable › Vulnerabilities
CVE-2021-41265: Improper Authentication in Flask-AppBuilder
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-09 · updated 2026-06-17
- Weakness: CWE-287
Description
Flask-AppBuilder is a development framework built on top of Flask. Verions prior to 3.3.4 contain an improper authentication vulnerability in the REST API. The issue allows for a malicious actor with a carefully crafted request to successfully authenticate and gain access to existing protected REST API endpoints. This only affects non database authentication types and new REST API endpoints. Users should upgrade to Flask-AppBuilder 3.3.4 to receive a patch.
Affected products
- dpgaspar Flask-AppBuilder: before 3.3.4 — fixed in 3.3.4
How to fix
Upgrade to a fixed version: dpgaspar Flask-AppBuilder 3.3.4. Check the vendor advisory for mitigations.
References
- https://github.com/dpgaspar/Flask-AppBuilder/commit/eba517aab121afa3f3f2edb011ec6bc4efd61fbc
- https://github.com/dpgaspar/Flask-AppBuilder/releases/tag/v3.3.4
- https://github.com/dpgaspar/Flask-AppBuilder/security/advisories/GHSA-m3rf-7m4w-r66q
- https://github.com/dpgaspar/Flask-AppBuilder/commit/eba517aab121afa3f3f2edb011ec6bc4efd61fbc
- https://github.com/dpgaspar/Flask-AppBuilder/releases/tag/v3.3.4
- https://github.com/dpgaspar/Flask-AppBuilder/security/advisories/GHSA-m3rf-7m4w-r66q
Get alerted when CVE-2021-41265 or the next vulnerability affects your stack