What’s Vulnerable › Vulnerabilities
CVE-2021-41276: Indirect LDAP injection in Tuleap
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-15 · updated 2026-06-17
- Weakness: CWE-74
Description
Tuleap is a Libre and Open Source tool for end to end traceability of application and system developments. In affected versions Tuleap does not sanitize properly the search filter built from the ldap_id attribute of a user during the daily synchronization. A malicious user could force accounts to be suspended or take over another account by forcing the update of the ldap_uid attribute. Note that the malicious user either need to have site administrator capability on the Tuleap instance or be an LDAP operator with the capability to create/modify account. The Tuleap instance needs to have the LDAP plugin activated and enabled for this issue to be exploitable. This issue has been patched in Tuleap Community Edition 13.2.99.31, Tuleap Enterprise Edition 13.1-5, and Tuleap Enterprise Edition 13.2-3.
Affected products
- Enalean tuleap: before 13.2.99.31; from 13.1-1 before 13.1-5; from 13.2-1 before 13.2-3 — fixed in 13.1-5, 13.2-3, 13.2.99.31
How to fix
Upgrade to a fixed version: Enalean tuleap 13.1-5, 13.2-3, 13.2.99.31. Check the vendor advisory for mitigations.
References
- https://github.com/Enalean/tuleap/commit/bd47f29847fcd6a68d359bc8aefb8749bb8a1b7c
- https://github.com/Enalean/tuleap/security/advisories/GHSA-887w-pv2r-x8pm
- https://tuleap.net/plugins/git/tuleap/tuleap/stable?a=commit&h=bd47f29847fcd6a68d359bc8aefb8749bb8a1b7c
- https://tuleap.net/plugins/tracker/?aid=24149
- https://github.com/Enalean/tuleap/commit/bd47f29847fcd6a68d359bc8aefb8749bb8a1b7c
- https://github.com/Enalean/tuleap/security/advisories/GHSA-887w-pv2r-x8pm
- https://tuleap.net/plugins/git/tuleap/tuleap/stable?a=commit&h=bd47f29847fcd6a68d359bc8aefb8749bb8a1b7c
- https://tuleap.net/plugins/tracker/?aid=24149
Get alerted when CVE-2021-41276 or the next vulnerability affects your stack