What’s Vulnerable › Vulnerabilities
CVE-2021-4130: Cross-Site Request Forgery (CSRF) in snipe/snipe-it
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-12-18 · updated 2026-06-17
- Weakness: CWE-352
Description
snipe-it is vulnerable to Cross-Site Request Forgery (CSRF)
Affected products
- grokability snipe-it: before 5.3.6 — fixed in 5.3.6
How to fix
Upgrade to a fixed version: grokability snipe-it 5.3.6. Check the vendor advisory for mitigations.
References
- https://github.com/snipe/snipe-it/commit/9b2dd6522f214a3fbee6a4e32699104d0ea2b6ae
- https://huntr.dev/bounties/ccf073cd-7f54-4d51-89f2-6b4a2e4ae81e
- https://github.com/snipe/snipe-it/commit/9b2dd6522f214a3fbee6a4e32699104d0ea2b6ae
- https://huntr.dev/bounties/ccf073cd-7f54-4d51-89f2-6b4a2e4ae81e
Get alerted when CVE-2021-4130 or the next vulnerability affects your stack