What’s Vulnerable › Vulnerabilities
CVE-2021-41303: Apache Shiro before 1.8.0, when using Apache Shiro with Spring Boot, a specially crafted HTTP request may cause an authentication bypass
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 76.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-09-17 · updated 2026-06-17
- Weakness: CWE-287
Description
Apache Shiro before 1.8.0, when using Apache Shiro with Spring Boot, a specially crafted HTTP request may cause an authentication bypass. Users should update to Apache Shiro 1.8.0.
Affected products
- Apache Software Foundation Apache Shiro: before 1.8.0 — fixed in 1.8.0
- Oracle Financial Services Crime And Compliance Management Studio: 8.0.8.2.0, 8.0.8.3.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Shiro 1.8.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/raae98bb934e4bde304465896ea02d9798e257e486d04a42221e2c41b%40%3Cuser.shiro.apache.org%3E
- https://lists.apache.org/thread.html/re470be1ffea44bca28ccb0e67a4cf5d744e2d2b981d00fdbbf5abc13%40%3Cannounce.shiro.apache.org%3E
- https://security.netapp.com/advisory/ntap-20220609-0001/
- https://www.oracle.com/security-alerts/cpujul2022.html
- https://lists.apache.org/thread.html/raae98bb934e4bde304465896ea02d9798e257e486d04a42221e2c41b%40%3Cuser.shiro.apache.org%3E
- https://lists.apache.org/thread.html/re470be1ffea44bca28ccb0e67a4cf5d744e2d2b981d00fdbbf5abc13%40%3Cannounce.shiro.apache.org%3E
- https://security.netapp.com/advisory/ntap-20220609-0001/
- https://www.oracle.com/security-alerts/cpujul2022.html
Get alerted when CVE-2021-41303 or the next vulnerability affects your stack