What’s Vulnerable › Vulnerabilities
CVE-2021-41304
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-10-26 · updated 2026-06-17
- Weakness: CWE-79
Description
Affected versions of Atlassian Jira Server and Data Center allow anonymous remote attackers to inject arbitrary HTML or JavaScript via a Cross-Site Scripting (XSS) vulnerability in the /secure/admin/ImporterFinishedPage.jspa error message. The affected versions are before version 8.13.12, and from version 8.14.0 before 8.20.2.
Affected products
- Atlassian Data Center: before 8.13.12 — fixed in 8.13.12
- Atlassian Jira: before 8.13.12 — fixed in 8.13.12
- Atlassian Jira: from 8.14.0 before 8.20.2 — fixed in 8.20.2
- Atlassian Jira: from 8.14.0 before 8.20.2 — fixed in 8.20.2
How to fix
Upgrade to a fixed version: Atlassian Data Center 8.13.12; Atlassian Jira 8.13.12; Atlassian Jira 8.20.2; Atlassian Jira 8.20.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2021-41304 or the next vulnerability affects your stack